среда, 10 августа 2016 г.

Установка свежих версий Xfce и Cinnamon в Debian 8

Наконец-то дошли руки написать эту заметку :) В своём репозитории для Debian 8 я подготовил два подроекта, с графическими окружениями Cinnamon и Xfce. Туда будут добавляться свежие версии этих окружений. Нужность этих репозиториев в том, что Cinnamon в Debian 8 очень старый (версии 2.2), а Xfce очень плохо работает с современными GTK3-приложениями (к примеру лепит два заголовка окна приложениям, использующим Client-Side Decorations, или CSD). Потому теперь у пользователей Debian 8 есть возможность обновить эти два рабочих окружения.

Ничего сложного в этом нет. Открываем файл /etc/apt/sources.list в любимом текстовом редакторе (с правами root!) и добавляем адрес репозитория:

#Cinnamon
deb http://download.opensuse.org/repositories/home:/Sunderland93:/cinnamon/Debian_8.0/ /

#Xfce
deb http://download.opensuse.org/repositories/home:/Sunderland93:/xfce4/Debian_8.0/ /

Сохраняем. Скачиваем ключ репозитория:

Для Cinnamon:
wget http://download.opensuse.org/repositories/home:Sunderland93:cinnamon/Debian_8.0/Release.key && sudo apt-key add - < Release.key

Для Xfce:
wget http://download.opensuse.org/repositories/home:Sunderland93:xfce4/Debian_8.0/Release.key && sudo apt-key add - < Release.key

Обновляем список пакетов и производим апгрейд окружения:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade

Вот и всё!

21 комментарий:

  1. Алексей,на твой взгляд ставить новую версию Cinamon желательно или можно тихонько на старой быть?

    ОтветитьУдалить
  2. Если бы там хотя бы 2.6 стоял по умолчанию - можно было бы и оставить, но 2.2 - это уже слишком, на мой взгляд. Весь наиболее удобный функционал появился в 2.4 и 2.6

    ОтветитьУдалить
  3. Алексей, в репозитории я так понимаю версия Cinnamon 3? Насколько она стабильна?

    ОтветитьУдалить
    Ответы
    1. Настолько же, насколько и остальные версии Cinnamon. Мелкие глюки есть, но они есть везде. Был баг, когда SMplayer/MPV ронял оконный менеджер после просмотра в полноэкранном режиме, но его пофиксили

      Удалить
    2. Алексей, спасибо! Есть Какие-то специальные требования по установке? Просто при установки на версию из коробки происходит крах при запуске. Может что то я не так делаю? Спасибо

      Удалить
  4. Неизвестный тип «Cinnamon» в строке 1 в списке источников /etc/apt/sources.list
    Что делать?

    ОтветитьУдалить
  5. Добавил ваш репозиторий для XFCE обновился но у некоторых приложений как было два заголовка окна так и остались.

    ОтветитьУдалить
    Ответы
    1. Возможно остались конфиги от предыдущей версии

      Удалить
    2. А есть смысл потушить иксы и потом обновится?

      Удалить
  6. обновление прошло без каких-либо ошибок. НО! после перезагрузки и ввода логина/пароля вижу сообщение "Failed to load session 'cinnamon'" (пруф http://prntscr.com/db354g)

    ОтветитьУдалить
  7. Спасибо за репозиторий для XFCE, обновился - багов нет, всё работает, это лучше чем я обновлятся из testing, несколько раз пробовал и всё не как у людей.

    ОтветитьУдалить
  8. Вот я обновил Xfce до 4.12 таким способом. Поработал и вижу, что не нравится. Система более тормознутая стала, есть раздражающие моменты. Как вернуться обратно на Xfce 4.10?

    ОтветитьУдалить
    Ответы
    1. 1) Удалить репозиторий;
      2) Обновить список пакетов;
      3) sudo apt install -t jessie xfce4 xfce4-goodies
      4) sudo apt-get autoremove

      Удалить
    2. Дохожу до пункта 3 и получаю:
      Чтение списков пакетов… Готово
      Построение дерева зависимостей
      Чтение информации о состоянии… Готово
      Уже установлена самая новая версия xfce4-goodies.
      Уже установлена самая новая версия xfce4.
      обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
      Даунгрейд не удался.

      Удалить
    3. Можно попробовать ещё выполнить полное обновление системы, чтобы она посмотрела какие пакеты не из стандартных репов:

      sudo apt-get dist-upgrade

      Удалить
    4. Тоже не сработало.

      sudo apt-get dist-upgrade
      Чтение списков пакетов… Готово
      Построение дерева зависимостей
      Чтение информации о состоянии… Готово
      Расчёт обновлений…Готово
      обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.

      Придется, видимо, мириться с тем, что не устраивает, и пользоваться тем, что имею. Думаю, может тогда мне на testing переключиться и обновить пакеты для их xfce 4.12. Что думаете по этому поводу?

      Удалить
    5. Я имеено из тестинга их бэкпортировал

      Удалить
  9. А как например установить только xfwm? Что то в репах не нашел.

    ОтветитьУдалить